ホーム インフォメーション一覧 > インフォメーション詳細

インフォメーション詳細

【重要】PHPバージョンアップメンテナンスのお知らせ 10月1日実施予定   [ 2015.09.10 ]

この度、ホスティングサービスにて提供しておりますPHPにつきまして、
安定性向上の為、PHP-5.3からPHP-5.5へのバージョンアップを実施させて
いただきます。

バージョンアップ実施の背景といたしましては、PHP-5.3のサポート終了に伴い、
今後、PHP-5.3に何らかの脆弱性などがあった場合に、提供元からのサポートを
受けられず、対処が行えない可能性があるためでございます。

本メンテナンス以降は拡張子「.php」ではPHP-5.3がご利用いただけなくなり、
PHP-5.5として実行されます。
PHP-5.3をご利用の場合は、拡張子を「.php」から「.php53」と変更していただく
必要がございます。

詳細は下記の通りとなりますので、ご確認のほどよろしくお願いいたします。

--------------------------------------------------------------------------
【第3回メンテナンス】※第1回、第2回メンテナンスについては既に完了しております。

[作業実施日時]
2015年10月1日(木) 10:00 から
2015年10月1日(木) 13:00 まで

[対象]
S-ミニ・レギュラー・プロにてphpをご利用のお客さま

[作業内容]
PHP-5.3の環境を完全に廃止いたします。

※※重要※※
この段階で、PHP-5.5のみ利用が可能な環境となります。
利用可能なPHPの拡張子は「.php」「.php5」「.php55」となります。
--------------------------------------------------------------------------
上記バージョンアップ作業に伴い、お客さまのウェブコンテンツ作成の方法により、
スクリプトの記述修正が必要な場合がございます。

恐れ入りますが、注意事項をご確認の上、適宜ご対応いただけますようお願い申し上げま
す。


●お客さま状況別対応方法

・フリー素材のPHPスクリプトをご利用のお客さま
→ご利用のPHPスクリプトについては、配布元に仕様をご確認ください。

・ホームページ製作会社に製作を依頼されたお客さま
→本内容をホームページ製作会社にご連絡の上、ご対応いただいてください。

・ご自身でホームページを製作されたお客さま
→PHP公式サイトよりバージョン差異による変更点を確認し、適宜修正をお願いいたしま
す。

PHP 5.3.x から PHP 5.4.x への移行に際しての変更点
http://php.net/manual/ja/migration54.php

PHP 5.3.x から PHP 5.4.x への移行 下位互換性のない変更点
http://php.net/manual/ja/migration54.incompatible.php

PHP 5.4.x から PHP 5.5.x への移行に際しての変更点
http://php.net/manual/ja/migration55.php

PHP 5.4.x から PHP 5.5.x への移行 下位互換性のない変更点
http://php.net/manual/ja/migration55.incompatible.php

--------------------------------------------------------------------------

以上でございます。

本メンテナンスにつきまして、お客さまには大変ご迷惑をおかけいたしますが、
ご提供サービスの安定運用に必要な対応のため、何卒ご理解を賜りますよう
お願い申し上げます。



一覧に戻る